Dane DEM po raz kolejny .....

O seriach 62, Montana, Oregon, eTrex, czy fēnix, a nawet Rino, Dakota, Colorado, czy starej dobrej 60. Także o oprogramowaniu BaseCamp oraz mapach topograficznych i turystycznych (w tym o GPMapie Topo i Garmin Custom Maps) oraz o wszystkim co związane z użytkowaniem GPSów na szlakach górskich, krajoznawczych i rowerowych, a nawet w przydomowym lesie.

Moderatorzy: Spider, Magnoom, GPS Maniak

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 11:57

Moim zdaniem powinny być takie takie same ale przyznaję że nie sprawdzałem.
Pytanie - czy wersja UMPa (w sensie skórki), którą masz w odbiorniku współpracuje prawidłowo z DEM_100 z parametrami jw. (23; 1,4,13,1) lecz nie chce współpracować z DEM_50 z takimi samymi parametrami?
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Re: Dane DEM po raz kolejny .....

Postprzez Mariusz65 » Śr, 12 gru 2012 12:43

Tak!
DEM_100 współpracuje z UMP (skórka dostosowana) prawidłowo, natomiast DEM_50 przykrywa UMPa. Nawet po zmianie parametrów GmapToolem na takie jak podałeś :?
Pozdrawiam Mariusz
W aucie: Nüvi 255 (FW 6.60) + UMP-pcPL - the best
W kieszeni: Dakota 20
Avatar użytkownika
Mariusz65
Moderator
 
Posty: 4462
Dołączył(a): Cz, 20 sie 2009 14:02
Lokalizacja: N52.8° E18.8°

Re: Dane DEM po raz kolejny .....

Postprzez asandrzej » Śr, 12 gru 2012 12:49

Sprawdź jakie masz faktyczne ustawienie pierwszego parametru TRE w mapie DEM_100
andrzej
" Jak to nie zachwyca Galkiewicza, jeśli tysiąc razy tłumaczyłem Galkiewiczowi, że go zachwyca,"
z mapami i GPS-em jest podobnie.
cytat: Witold Gombrowicz
Palmtop-aplikacja Garmin Que
asandrzej
Bywalec
 
Posty: 6094
Dołączył(a): Śr, 13 lut 2008 20:24

Re: Dane DEM po raz kolejny .....

Postprzez Mariusz65 » Śr, 12 gru 2012 12:53

Zmieniłem na takie jak podał Lechu. Bez zmiany DEM_100 też nie działała. (przykrywa UMPa)
Pozdrawiam Mariusz
W aucie: Nüvi 255 (FW 6.60) + UMP-pcPL - the best
W kieszeni: Dakota 20
Avatar użytkownika
Mariusz65
Moderator
 
Posty: 4462
Dołączył(a): Cz, 20 sie 2009 14:02
Lokalizacja: N52.8° E18.8°

Re: Dane DEM po raz kolejny .....

Postprzez asandrzej » Śr, 12 gru 2012 12:57

O ile pamiętam, to UMP ma parametr 25, aby zmiana parametru miała skutek, to różnica powinna być przynajmniej 2,
Spróbuj obniżyć pierwszy dwucyfrowy parametr.( w DEM_50 )
andrzej
" Jak to nie zachwyca Galkiewicza, jeśli tysiąc razy tłumaczyłem Galkiewiczowi, że go zachwyca,"
z mapami i GPS-em jest podobnie.
cytat: Witold Gombrowicz
Palmtop-aplikacja Garmin Que
asandrzej
Bywalec
 
Posty: 6094
Dołączył(a): Śr, 13 lut 2008 20:24

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 13:06

Nie ukrywam, że od czasu kiedy zostałem tylko z eTrexem wszelkich prób podejmuję się niechętnie, bo to świetny odbiornik w góry ale do zabawy już nie bardzo :wink:
OK. Przyjrzę się problemowi.
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Re: Dane DEM po raz kolejny .....

Postprzez Mariusz65 » Śr, 12 gru 2012 13:07

@Andrzej - Gdyby to wystarczyło to przy takich samych parametrach działałoby zarówno z DEM_100 jak z DEM_50 !
Tym czasem DEM_100 po zmianie parametrów (23; 1,4,13,1) jest OK. a DEM_50 nie.

@Lechu - Dzięki!
Pozdrawiam Mariusz
W aucie: Nüvi 255 (FW 6.60) + UMP-pcPL - the best
W kieszeni: Dakota 20
Avatar użytkownika
Mariusz65
Moderator
 
Posty: 4462
Dołączył(a): Cz, 20 sie 2009 14:02
Lokalizacja: N52.8° E18.8°

Re: Dane DEM po raz kolejny .....

Postprzez asandrzej » Śr, 12 gru 2012 13:21

Mariusz65 napisał(a):Gdyby to wystarczyło to przy takich samych parametrach działałoby zarówno z DEM_100 jak z DEM_50 !.

Pewności nigdy nie ma, jest to jednak inna mapa.
andrzej
" Jak to nie zachwyca Galkiewicza, jeśli tysiąc razy tłumaczyłem Galkiewiczowi, że go zachwyca,"
z mapami i GPS-em jest podobnie.
cytat: Witold Gombrowicz
Palmtop-aplikacja Garmin Que
asandrzej
Bywalec
 
Posty: 6094
Dołączył(a): Śr, 13 lut 2008 20:24

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 17:07

@Mariusz. Wersji UMPa więcej niż ja mam lat. O skórkach nie wspomnę :wink:
Zróbmy tak - wyegeneruj pojedynczy, nieduży arkusz UMPa ze skórką jaką używasz i podeślij do mnie.
Przykładowo niech to będą Sudety Zachodnie - mają ok. 6 MB.
Obejrzę i skórkę i zachowanie mapy z DEM_100 oraz DEM_50.
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Re: Dane DEM po raz kolejny .....

Postprzez Mariusz65 » Śr, 12 gru 2012 18:28

OK! Wysłałem na maila.

GPS Maniak napisał(a):Wersji UMPa więcej niż ja mam lat.

To nie jesteś jeszcze taki stary ;-)
Pozdrawiam Mariusz
W aucie: Nüvi 255 (FW 6.60) + UMP-pcPL - the best
W kieszeni: Dakota 20
Avatar użytkownika
Mariusz65
Moderator
 
Posty: 4462
Dołączył(a): Cz, 20 sie 2009 14:02
Lokalizacja: N52.8° E18.8°

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 18:44

Przyszło. W międzyczasie sprawdziłem sobie jakąś przedwojenną wersję UMPa (sierpień 2012) w wersji FID 122. Faktycznie DEM_50 z tymi samymi parametrami co DEM_100 zasłania UMPa :shock:
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 18:58

Być może problem jest związany z układem warstw. Oto parametry UMPa (122):

priorytet 23, parametry 1 3 17 13
levels [15,16,18,20,22,24], zoom [85,4,3,2,1,0]

DEM_100:

priorytet 23, parametry 1 4 13 1
levels [15,16,18,20,22,24], zoom [85,4,3,2,1,0]

Jak widać układ leveli jest zgodny, podczas gdy DEM_50:

priorytet 23, parametry 1 4 13 1
levels [18,19,21,22,23,24], zoom [85,4,3,2,1,0]

Krótko mówiąc nie wykluczone, że musiałbym wygenerować DEM_50 z innym układem warstw - specjalnie dla UMPa.
Z drugiej strony logika ta nie do końca jest ... logiczna :mrgreen: bowiem DEM_100 jw. bez problemu cieniuje mapę PL_Topo_2012, która ma taki układ warstw jak DEM_50. Ki czort?
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 19:26

Zanim zacznę grzebać w mapie DEM - uwaga na temat pliku TYP.
Jak dla mnie jest on błędny. Publikuję nowy, w którym trzeba zmienić nazwę.
Dlaczego plik jest moim zdaniem zły? Pisałem kiedyś o tym na Garniaku. Powtórzę.
Otóż chodzi o to, że - tak przynajmniej mi się wydaje - nie da się przewidzieć w jakiej kolejności Garmin wyrysuje obiekty z takim samym DrawOrder.

W przykładowej, hipotetycznej sytuacji gdy np. las będzie miał DO=2 oraz woda też DO=2, a w lesie nie będzie wycięta dziura na jezioro może się zdarzyć, że wyświetlone przez odbiornik wcześniej niż las jezioro, po prostu zniknie. Dlatego też dla bezpieczeństwa - tzn. na wszelki słuczaj gdyby w mapie były bugi (brak dziury w lesie) z reguły daje się dla wody DO wyższe niż dla lasu.

Jak jest w UMPie z lasem i wodą nie sprawdzałem, ale wiem że w celu uniknięcia brązowej przebitki na cieniowaniu dokładamy obiekt background (domyślnie DO=0) nadając mu parametr DO=1. W efekcie trudno przewidzieć co będzie się działo z innymi obiektami posiadającymi DO=1. Istnieje ryzyko że znikną (znikający Bałtyk :wink: ) zasłonięte backgroundem. Tak więc dla wszystkich obiektów z DO=1 zmieniamy ten wpis na DO=2. Oczywiście w celu zachowania hierarchii wyświetlania, konsekwencją tego działania jest to, że wszystkie DO=2 przerabiamy na DO=3 etc. etc.

Stary nagłówek:

Zalacznik1.jpg


Nowy nagłówek:

Zalacznik2.jpg


Plik TYP:
RECZNIAK_NEW.7z
(19.6 KiB) Pobrane 110 razy
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Re: Dane DEM po raz kolejny .....

Postprzez Mariusz65 » Śr, 12 gru 2012 20:38

Skórka przetestowana!
Zainteresowanym napiszę, że to do wersji UMP Pełnej FID - 122
Pozdrawiam Mariusz
W aucie: Nüvi 255 (FW 6.60) + UMP-pcPL - the best
W kieszeni: Dakota 20
Avatar użytkownika
Mariusz65
Moderator
 
Posty: 4462
Dołączył(a): Cz, 20 sie 2009 14:02
Lokalizacja: N52.8° E18.8°

Re: Dane DEM po raz kolejny .....

Postprzez GPS Maniak » Śr, 12 gru 2012 20:43

Jeżeli chodzi o DEM_50, będziesz jednak musiał uzbroić się w ... dużą cierpliwość. Póki nie wygeneruję nowej mapy (a to niewiadomo kiedy nastąpi) z innym układem leveli zapewne niczego nie osiągnę. Cały czas widzę brąz na ekranie. UMPa ani widu ani słychu :D
Pozdrawiam Lechu

Plecak: Garmin Fenix 5X + Xiaomi Mi Max 2 a czasami: Oregon 600T, Rino530HCX Był: Summit, Vista, 60CS, 60CSX, 62ST, eTrex30, eTrex10, Fenix3, Epix
Samochód: 3490T Był: 200, 205T, 1200T
Avatar użytkownika
GPS Maniak
Radny
 
Posty: 14830
Dołączył(a): Pt, 16 mar 2007 2:55
Lokalizacja: Poznań / Lesko

Poprzednia stronaNastępna strona

Powrót do Na szlaku

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zalogowanych użytkowników i 2 gości